[关闭]
@natsumi 2016-11-28T07:20:05.000000Z 字数 5174 阅读 2796

新的CentOS系统安装wireshark-2.0.2

Wireshark Linux


  1. checking for bison... no
  2. checking for byacc... no
  3. checking for yacc... no
  4. configure: error: I couldn't find yacc (or bison or ...); make sure it's installed and in your path
  1. checking for flex... no
  2. checking for lex... no
  3. checking for flex... no
  4. configure: error: I couldn't find flex; make sure it's installed and in your path
  1. Basic XLib functionality test failed!
  2. You might need to modify the include and library search paths by editing
  3. QMAKE_INCDIR_X11 and QMAKE_LIBDIR_X11 in /home/repair/software_installed/qt-everywhere-opensource-src-4.8.7/mkspecs/linux-g++.
  1. export QT_PC=/usr/local/Trolltech/Qt-4.8.7/lib/pkgconfig
  2. export PKG_CONFIG_PATH=$QT_PC

source /etc/profile使修改生效

  1. checking for uic-qt4... no
  2. checking for uic... no
  3. configure: error: I couldn't find uic-qt4 or uic; make sure it's installed and in your path

修改/etc/profile中之前添加的两行

  1. export QT_HOME=/usr/local/Trolltech/Qt-4.8.7/bin
  2. export PATH=$QT_HOME:$PATH
  3. export QT_PC=/usr/local/Trolltech/Qt-4.8.7/lib/pkgconfig
  4. export PKG_CONFIG_PATH=$QT_PC:$PKG_CONFIG_PATH
  1. checking for GLIB - version >= 2.16.0... no
  2. *** Could not run GLIB test program, checking why...
  3. *** The test program failed to compile or link. See the file config.log for the
  4. *** exact error that occured. This usually means GLIB is incorrectly installed.
  5. configure: error: GLib 2.16.0 or later distribution not found.
  1. configure: error: Package requirements (libffi >= 3.0.0) were not met:
  2. No package 'libffi' found
  1. checking for PCRE... no
  2. configure: error: Package requirements (libpcre >= 8.13) were not met:
  3. No package 'libpcre' found
  4. Consider adjusting the PKG_CONFIG_PATH environment variable if you
  5. installed software in a non-standard prefix.
  6. Alternatively, you may set the environment variables PCRE_CFLAGS
  7. and PCRE_LIBS to avoid the need to call pkg-config.
  8. See the pkg-config man page for more details.
  1. checking readline/readline.h usability... no
  2. checking readline/readline.h presence... no
  3. checking for readline/readline.h... no
  4. checking readline/history.h usability... no
  5. checking readline/history.h presence... no
  6. checking for readline/history.h... no
  7. checking for readline in -lreadline... no
  8. checking for readline in -lreadline... no
  9. checking for readline in -lreadline... no
  10. checking for readline in -lreadline... no
  11. checking for readline in -lreadline... no
  12. checking for readline in -lreadline... no
  13. ** Cannot --enable-pcretest-readline because readline/readline.h was not found.
  1. ** Cannot --enable-pcregrep-libbz2 because bzlib.h was not found
  1. checking for pcap-config... no
  2. checking for extraneous pcap header directories... found -- -I/usr/local/include added to CFLAGS
  3. checking pcap.h usability... no
  4. checking pcap.h presence... no
  5. checking for pcap.h... no
  6. configure: error: Header file pcap.h not found; if you installed libpcap
  7. from source, did you also do "make install-incl", and if you installed a
  8. binary package of libpcap, is there also a developer's package of libpcap,
  9. and did you also install that package?
  1. test@test:/usr/local/src/Mesa_build$ sudo make
  2. CDPATH="${ZSH_VERSION+.}:" && cd /install/Mesa-10.3.5 && /bin/bash /install/Mesa-10.3.5/bin/missing aclocal-1.14 -I m4
  3. /install/Mesa-10.3.5/bin/missing: line 81: aclocal-1.14: command not found
  4. WARNING: 'aclocal-1.14' is missing on your system.
  5. You should only need it if you modified 'acinclude.m4' or
  6. 'configure.ac' or m4 files included by 'configure.ac'.
  7. The 'aclocal' program is part of the GNU Automake package:
  8. <http://www.gnu.org/software/automake>
  9. It also requires GNU Autoconf, GNU m4 and Perl in order to run:
  10. <http://www.gnu.org/software/autoconf>
  11. <http://www.gnu.org/software/m4/>
  12. <http://www.perl.org/>
  13. make: *** [/install/Mesa-10.3.5/aclocal.m4] Error 127
添加新批注
在作者公开此批注前,只有你和作者可见。
回复批注