[关闭]
@HaomingJiang 2016-06-05T02:35:22.000000Z 字数 1378 阅读 1440

Tensorflow installation guidance

tensorflow


环境

Ubuntu 14.04

Requirement

Python 2.7 or Python 3.3+.
Cuda Toolkit 7.5
cuDNN v4

先安装Cuda & cuDNN

Cuda:
1.下载 https://developer.nvidia.com/cuda-downloads
跟着他的教程一步步来就行

  1. $ sudo dpkg --install cuda-repo-<distro>-<version>.<architecture>.deb
  2. $ sudo apt-get update
  3. $ sudo apt-get install cuda

2.重启系统,加载NVIDIA驱动
3.添加环境变量(这里我的电脑怪怪的,好像不是全局变量,每一次在新的位置运行程序都要设置一遍)

  1. $ export PATH=/usr/local/cuda-7.5/bin:$PATH
  2. $ export LD_LIBRARY_PATH=/usr/local/cuda-7.5/lib64:$LD_LIBRARY_PATH

cuDNN:
https://developer.nvidia.com/cudnn
下载cuDNN v4 (要先注册)
把文件解压后放到Cuda安装位置对应的地方(e.g. /usr/local/cuda)

  1. $ tar xvzf cudnn-7.5-linux-x64-v4.tgz
  2. $ sudo cp cudnn-7.5-linux-x64-v4/cudnn.h /usr/local/cuda/include
  3. $ sudo cp cudnn-7.5-linux-x64-v4/libcudnn* /usr/local/cuda/lib64
  4. $ sudo chmod a+r /usr/local/cuda/lib64/libcudnn*

安装Pip(使用Pip安装,不过也有其他安装办法,这个比较简单)

  1. # Ubuntu/Linux 64-bit
  2. $ sudo apt-get install python-pip python-dev

使用Pip一键安装

  1. # Ubuntu/Linux 64-bit, CPU only:
  2. $ sudo pip install --upgrade https://storage.googleapis.com/tensorflow/linux/cpu/tensorflow-0.8.0-cp27-none-linux_x86_64.whl
  3. # Ubuntu/Linux 64-bit, GPU enabled. Requires CUDA toolkit 7.5 and CuDNN v4.
  4. $ sudo pip install --upgrade https://storage.googleapis.com/tensorflow/linux/gpu/tensorflow-0.8.0-cp27-none-linux_x86_64.whl

不过当然。。由于墙的问题。。如果能翻出去这个就没问题,否则需要下载到本地。再用命令sudo pip install --upgrade tensorflow-0.8.0-cp27-none-linux_x86_64.whl 就行。也不一定会被墙反正试试咯。
下载地址(我只传了with GPU的,没GPU的训练太慢了):
链接: http://pan.baidu.com/s/1dEZi8M1 密码: jdjz

添加新批注
在作者公开此批注前,只有你和作者可见。
回复批注